Ergebnis 1 bis 3 von 3

Thema: Linksys, elend langsame DHCP nach Authentifizierung

  1. #1
    Registered User
    Registriert seit
    Jun 2000
    Beiträge
    3.883
    Renommee
    719

    Linksys, elend langsame DHCP nach Authentifizierung

    Hi Leute,
    ich habe gerade ein äußerst merkwürdiges Problem mit Linksys. Auf mein Schreibtisch stehen 2 Accesspoints, ein Linksys WAP200 und ein Apple Airport. Beide sind (soweit möglich) identisch konfiguriert: WPA/WPA2 Enterprise -> Authentifizierung via ein freeradius. Beide sind flott beim fragen vom Radius Server und bekommen flott eine Antwort. Wenn ich mit denselben Client versuche mich beim Apple anzumelden geht das reine Anmelden schnell, und die DHCP Request dannach auch recht flott (Insgesamt ca. 5 sec.). Beim Linksys geht das Anmelden auch flott, aber es dauert ewig bis ich via DHCP eine Ip bekomme (Insgesamt ca. 65 sec.).
    Kennt einer das Phänomen, oder vielleicht Schlagwörter nach der ich im Internet suchen könnte? Das beschäftigt mich hier schon seit Stunden.
    Geändert von DopeFish (19.11.2008 um 16:25 Uhr)
    das kann man bestimmt auch in bash coden ...

  2. #2
    Registered User
    Registriert seit
    Jun 2000
    Beiträge
    3.883
    Renommee
    719

    Re: Linksys, elend langsame DHCP nach Authentifizierung

    Ok, scheint ein Bug von Linksys zu sein, wenn ich mit tcpdump da sganze mitschneide, sehe ich dass die DHCP Offer Unicasts wohl nicht ankommen wenn sie über den Linksys Accesspoint gehen. Wenn der DHCP Server den Offer als Broadcast schickt kommt es an.

    Wie behindert ist das denn, es kann doch nicht sein, dass ich der einzige bin der ein Linksys Accesspoint und DHCP benutzen will ?!? Kennt jemand eine Option für dhcpd damit er gleich die Antwort als Broadcast schickt?
    das kann man bestimmt auch in bash coden ...

  3. #3
    Registered User
    Registriert seit
    Jun 2000
    Beiträge
    3.883
    Renommee
    719

    Re: Linksys, elend langsame DHCP nach Authentifizierung

    habe es beim ersten mal im manpage übersehen. damit der dhcp die antworten als braodcast schickt gibt es folgende option. Damit habe ich zumindest ein Workaround bis ich eine Lösung finde.

    always-broadcast on;

    OffTopic:

    ist das angenehm wenn morgens keiner im Büro ist, da kann man in Ruhe arbeiten ;-)
    das kann man bestimmt auch in bash coden ...

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. [H2/SQL allg] Extrem langsame Abfrage
    Von Overlord im Forum Datenbanken
    Antworten: 1
    Letzter Beitrag: 19.01.2008, 17:36
  2. Linksys WRT54GS und VPN
    Von bendor im Forum Netzwerktopologie & Technik
    Antworten: 6
    Letzter Beitrag: 27.09.2006, 21:16
  3. langsame uhr, uhr geht nach
    Von bartman_ im Forum UNIX/Linux
    Antworten: 1
    Letzter Beitrag: 22.06.2004, 18:54
  4. Antworten: 9
    Letzter Beitrag: 18.07.2003, 13:48
  5. Antworten: 3
    Letzter Beitrag: 02.08.2002, 19:00

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •